Tuesday, April 17, 2012

2005 GMC ENVOY: Turn Signals Don't Work When Brakes Are Applied?

In this case the turn-signals stop working when brakes are applied.But otherwise the turn signal works.

On basis of this description the details and possibilities to troubleshoot the problem are as follows :-----

As its mentioned that turn signals are working,but stops only when brakes are applied.

This clears that turn multi-function signal switch is working.But still check / inspect the switch voltage and wiring.

Also recheck the brake light switch and its connections properly.

But if all this checked out perfectly ok.

Then read further
The problem you are experiencing is a bad ground to the taillights. Inspect the connectors at each taillight and make sure the connector and terminals are not damaged. If you have an ohmmeter, test for continuity to ground on the black wire. If you have no ohmmeter, connect a jumper wire to a good ground and then to the black wire at the taillight connector and see if this fixes the problem. If it does not then the problem is in the taillight socket plate. This is a common failure on the Envoy and is most likely in the taillight socket plates.

This details will help.
Thanks.


For All types of Car models and brands help

Go to Newly Launched


FREE Car repair guide?

http://technoanswers.blogspot.in/2012/03/car-repair-guide.html

&

Complete Car repair Help FREE?

http://repairhelpcenter.blogspot.in/2012/03/complete-car-repair-help.html

No comments:

Post a Comment